Sign in to follow this  
Followers 0
Fábio Senji

[RESOLVIDO] ..InterpretAmpersand N/A mas STC esconde o "&"

2 posts in this topic

Olá novamente.

Windev Mobile 25 aqui.

Estou com um STC dentro de um looper preenchido por programação. Tal STC recebe campos strings de um array de variants. Essas strings às vezes têm o caractere "&", que teoricamente pode ser reconhecido como indicador de pedido de "sublinhe o próximo caractere" para o STC. Só que tal opção de sublinhar, relativa à propriedade ..InterpretAmpersand, não está disponível para Android framework, e no dispositivo o caractere "&" some. Nem sublinha o próximo, apenas some. Tentei jogar numa string antes de mandar pro ATT_NomeDoItem do looper, e nada. Tentei ver (com trace/info) como está na string, e está com o "&" bonitinho, só que no STC o "&" some. Tentei dar Replace do & por alguma string que não vai surgir, jogar no ATT_NomeDoItem e trocar de volta ao displaying a row do looper... sem sucesso. No simulador tudo OK, no dispositivo some.

Alguma ideia? Não tem como exibir & num STC em mobile? Atualmente preciso exibí-lo.

Obrigado pela atenção

1 person likes this

Share this post


Link to post
Share on other sites

Resolvido.

sTituloCorrigido = Replace(sTituloCorrigido,"&","&&")

No simulador aparece &&, no dispositivo funciona.

Edited by Fábio Senji
3 people like this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0