• advertisement_alt
  • advertisement_alt
  • advertisement_alt
Ananias Guerra

WEBDEV Lentidão crescente do sistema

7 posts in this topic

O usuário clica em 'incluir', abre-se um popup para a inclusão dos dados.
Clica 'OK', verifica-se no Browser Code, se os campos estão devidamente preenchidos, se não estiver, mostro uma mensagem e o foco retorna para o campo onde está o problema.
Caso tudo esteja ok, é executado Server Code, que realiza o salvamento dos dados.

Na primeira inclusão, tudo normal.
A cada inclusão realizada, o sistema vai ficando cada vez mais lento. Não encontrei o problema nos logs, nem nas ferramentas de desenvolvedor do navegador.
Alguém que tenha notado isto em seu sistema poderia me dar uma dica do que pode estar acontecendo?

Share this post


Link to post
Share on other sites

somente com essas informações é impossível te ajudar
é fundamental analisar o projeto como um todo nesses casos, especificamente esse formulário
aqui temos sistema WEB rodando e não temos esse problema citado
coloque aqui imagens do form em questão e se tiver planes idem

2 people like this

Share this post


Link to post
Share on other sites

Fiz uma experiência aqui, clicando no botão que mostra o Popup (apenas chama o Popup e não executa mais nada) e retirando todos os códigos do Popup.
Então eu clico para exibir o Popup, clico para fechar o Popup.
Mesmo sem processar nada mais que isto, o sistema vai ficando cada vez mais lento.
No Browser vi esses logs de alerta:
 

Capturar.PNG

1 person likes this

Share this post


Link to post
Share on other sites

Ainda fiz mais: Coloquei no botão para chamar um Popup vazio, apenas com um botão para fechar, e continua o problema.
Estou pensando que é algo relativo a versão do Jquery utilizado no WEBDEV 23, será ?

Share this post


Link to post
Share on other sites

O erro de carregamento da fonte pode ser reparado colocando o CDN de acesso:

no HTML:

<link rel="stylesheet" href="//maxcdn.bootstrapcdn.com/elusive-icons/2.0.0/css/elusive-icons.min.css">

na Página Webdev:

https://maxcdn.bootstrapcdn.com/elusive-icons/2.0.0/css/elusive-icons.min.css

2 people like this

Share this post


Link to post
Share on other sites

Posted (edited)

Bom. Pelas pesquisas que fiz, o problema está relacionado realmente à quantidade de dados na página. Vou ter que dar uma enxugada nela.

 

 

ajaxproblem.PNG

Edited by Ananias Guerra
1 person likes this

Share this post


Link to post
Share on other sites

Ananias, por essa ultima imagem parece que a renderização esta carregada mesmo, outro detalhes a observação do Hugo é muito importante e em muitos casos provoca lentidão, outra observação, o google chrome costuma ficar lento por conta de algumas extensões

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now